[Excel 97- Menü aufrufen]

Grundlagen für Excel 97

Kursmitschrift; erfordert deshalb etwas miträtseln )



Weiterführend:

Tips & Tricks für Excel (Erweitert)

Datum & Zeit in Excel

Weitere Tips für den Umgang mit Excel



 


^   Allgemein:





*********



Struktur: Mappen ( Arbeitsblätter; Tabellen ) 1, 2, 3 . . . ; diese werden gespeichert.
Tabellen umbenennen: Doppelklick auf den Namen oder rechte Maustaste; hier auch: Tabelle löschen. Mit [ Umschalt ] alle oder mit [ Strg ] mehrere umbenennen ( unschädlich innerhalb einer Mappe )
Darstellungs - Fehler: · ######## erscheint, wenn die Spalte zu schmal geworden ist, um den Inhalt darzustellen
· In Zahlen keine Dezimalpunkte eingeben; das erzeugt das Format "Datum".

Ebenso erzeugt ein Gemisch aus Zahlen und Buchstaben eine Zahl - wenn die Zelle nicht als "Text" formatiert wurde:  Format / Zellen / Zahlen / Text  
· Bei unklaren Fehlern: Bearbeiten / Löschen /  Formate
oder Bearbeiten / Löschen / Alles
-> Eine leere Zelle ( ein leeres Tabellenfeld ) ist nicht gleich 0!
Feldinhalt verändern: Den Cursor in das gewünschte Feld bewegen und [ F2 ] drücken: öffnet das Feld. ( statt Mausklick )
Weitere Möglichkeiten: Rechte Maustaste auf Extras / Steuerelemente-Toolbox
Hilfe finden: In den Menüs: [ F1 ] ( Auch zu den Registrierblättern )
Nur Werte einfügen: Inhalte Einfügen / Werte
Mustervorlage erstellen: Speichern unter / Dateityp / Mustervorlage ( .xlt statt .xls )
HTML erstellen: Bereich markieren und als HTML abspeichern
? und * Suchen: ~? und ~*, sonst dienen sie als Platzhalter



 

^   Tabellen Kopieren :

 
 

  1. Zellen Markieren und mit [ Strg ] + [ C ] kopieren ( übernimmt aber nicht die Spaltenbreite! ) 

  2. Spalten mit Köpfen markieren ( übernimmt die Spaltenbreite! ) 

  3. Verschieben mit [ Umschalt ] , Kopieren mit [ Strg ]




^   Zellen:

 



^  Zellen- Inhalte können sein:


1. Alphanumerische Informationen: Text, beliebig lang ( ? ); Ausrichtung links 
2. Numerische Informationen: 0 - 9 + , - , Dezimalstellen, Tausender- Punkt oderSymbol
3. Datum: Jahr bis 29 gilt als 2029, ab 30 als 1930; Ausrichtung rechts. Fehler werden als Text interpretiert.
4. Objekte ( nicht an Zelleninhalte gebunden )
5. Datenbankmodule von Excel




****************



Kopieren von Zellen: Mit [ Strg ] + [ C ] oder [ Strg ] + Ziehen des Ankers [ + ] unten rechts in der Zelle
Verschieben von Zellen: Ziehen des Zellrahmens




****************



^  Im Spalten- und Zeilenkopf ( grau ):

 



^   Zellenformate:


Es gibt prinzipiell Text, Uhrzeit, Währung, Zahl, Prozent,

sowie benutzerdefinierte Unterformatierungen über

Format / Zellen / Zahlen / Benutzerdefiniert
( am Ende der Liste )

wo per Hand beliebige eigene Formate codiert werden können; z. B. :

0000000   oder   00-000-K

Auch für Datumsformat, auch ohne Punkt, auch mit Leerzeichen, Kommata, etc. etc.. Textvorgabe dabei in Anführungszeichen setzen.



^  Es gilt für benutzerdefinierte Formate:




Prozente:

Teil/Gesamt*100
oder
Teil/Gesamt
 
mit Zellenformat "Prozent" ( - sonst ist das Ergebnis um den Faktor 100 zu hoch )



Zahlen in Klammern:

"("0")"


Excel 97 - Tabelle: Zahlenformate



 

Beispiele: Währung


Euro:

  1. Zelle als Währung formatieren;

  2. Format / Zellen / Zahlen / Benutzerdefiniert;

  3. " DM" durch " EUR" oder durch das Euro- Zeichen [ Alt Gr ] + [ E ] ) ersetzen. ( Nur ab dem Word 97 Update )



  1. Aber Vorsicht: In der Zelle ist nur die eingegebene Zahl als Information gespeichert->

  2. Benutzerdefinierte Formate gelten nur in dieser einen Tabelle; wenn gewünscht, kann daraus aber eine Vorlage für andere erstellt werden

  3. Achtung! Formatierungen bleiben auch nach dem Löschen des Zelleninhalts erhalten.

    Deshalb:


    Standardformat hestellen:  [ Strg ] + [ Umschalt ] + [ & ]

    oder Bearbeiten / Löschen / Formate
    oder Bearbeiten / Zeilen löschen




****************



^   Zellen verbinden:


Symbol: [< – a – >] : Zellen verbinden und Text zentrieren

Zurück: Format / Zellen / Ausrichtung: "Zellen Verbinden"   deaktivieren



Zeilenumbruch in einer Zelle:

[ Alt ] + [ Enter ]  oder Format / Zellen / Ausrichtung / Zeilenumbruch ( Nur für markierte Zellen gültig )

Falls es nicht klappt ( Fehleranzeige ####### ), die Zellen zusätzlich mit Format / Zellen / Zahlen / Wissenschaft formatieren.





****************




^   Bereich schützen:

 


Extras / Schutz / . . . etc.

 -> Vorher: freibleibend sollende Zellen ( Eingabebereiche ) markieren und in Format / Zellen / Schutz den Haken vor "Gesperrt" entfernen!
 
 


****************




^  Daten sortieren und filtern:

 


Excel sortiert wie auch Word nach Datum, aber nur wenn die Spalte auch korrekt als Datum formatiert wurde!


Zum Sortieren immer das ganze Blatt / die ganze Tabelle markieren, sonst geht die innere Zuordnung der Daten für immer verloren!




 -> Vorher muß über Extras / Schutz / . . . etc. der Blattschutz aufgehoben werden.
 
 



 -> Um nur die sichtbaren Zellen zu kopieren, anschließend den gewünschten Bereich markieren, dann in Bearbeiten / Gehe zu / Inhalte / Nur sichtbare Zellen aktivieren



****************




^  Daten trennen und zusammenführen:

 

Z.B. "Nachname, Vorname" in einer Spalte trennen ( d. h.die als "Nachname, Vorname" in einer Spalte geführten Namen aufteilen in zwei einzelne Spalten: "Nachname" und "Vorname" )

über Daten / Text in Spalten / ...

Vorher muß die Spalte markiert und ggf. über Extras / Schutz / . . . etc. der Blattschutz aufgehoben werden.  


Die Daten können nun neu sortiert wieder zusammengeführt werden über:

=(A1 &" "& B1)

Auf die gleiche Art können Zahlen in Text umgewandelt werden:

=(A1 &" + "& B1 &" = "& C1)

oder Worte und Zahlen kombinieren ( das Ergebnis mit einer Text - Vorgabe versehen ):

=("auf" & B1 & "km") oder =("auf" & B1 & " " & D1)    [ D1 = Dimension, variabel ]


- allerdings kann Excel mit diesem Wert nicht weiter rechnen; das geht nur bei global benutzerdefinierten Zellenformaten.








^   Formeln I - Eingabe:



^  Formeln



 

Formeleingabe mit Maushilfe:

( Beispiele )



^  Fehlermeldungen:

· #WERT! Wenn Excel versehentlich Text berechnen soll.

Achtung: die Funktion SUMME() ignoriert diese Fehler; sie addiert auch Listen mit fehlerhaften oder fehlenden Inhalten!

· #BEZUG Über rechte Maustaste: Inhalte Einfügen / Verknüpfen
· #NAME! Formelfehler. Prüfen: Was wurde nicht großgeschrieben?
/ alles klein schreiben. Textfehler: Text ohne "Anführungszeichen" ?
· ####### Spalte zu schmal
· #DIV/0! Formelfehler. Wert nicht vorhanden; Zelle leer oder Division durch Null.
Abhilfe: Formel =WENN(D3>0;F3/D3;"")
oder =WENN(FEHLER.TYP(G3)=2; "Wert steht nicht zur Verfügung"; G3)
[ Aus der Excel - Hilfe ]
· #NV Formelfehler. Wert nicht verfügbar; Zelle leer o. a. Abhilfe:
=WENN(FEHLER.TYP(E50)=7; "Wert steht nicht zur Verfügung"; E50)
[ Aus der Excel - Hilfe ]




^   Weitere Formeln:


· MIN
· MAX(AX:BY) Achtung: Doppelpunkt! }
· MITTELWERT
· ANZAHL { = ANZAHL der mit NUMERISCHEN Daten belegten Felder im markierten Bereich }
Numerische Werte = 0 - 9, + ,  -, je nach Format Punkt und Komma, Währungssymbol und % }
· ANZAHL2 { = ANZAHL der mit IRGENDWELCHEN Daten belegten Felder im markierten Bereich }
· ABRUNDEN(AX;2) Rundet auf zwei Stellen ab
· AUFRUNDEN(AX;2) Rundet auf zwei Stellen auf
· AUFRUNDEN(AX;0) oder
RUNDEN oder
GANZZAHL ergibt Ganze Zahl
· RUNDEN(AX;-2) Rundet zwei Stellen vor dem Komma auf
· HEUTE() Aktuelles Datum
· HEUTE()/AX Datumsberechnung
· AX^a Potenzieren
· AX^(1/a) Wurzelziehen





****************




^   Währungsformat:

 


^   Mehrwertsteuer:


Netto = AX/1,16

Excel 97 - Tabelle: Mehrwertsteuer 1



Bei Währungsformat:

=RUNDEN(AX/1,16;2) { = auf 2 Stellen }


Sonst können bei Division Nachkomma- Fehler auftreten!



Excel 97 - Tabelle: Runden










^   Formeln II - Funktion:



 

 

^   Absolute Zelladressen herstellen:

 

^   Namensvergabe an Zellen:

Definierte Namen ersetzen Hilfszellen

Man benötigt häufig bestimmte Konstanten oder Variablen, etwa die Mehrwertsteuer oder den Namen des aktuellen Monats.

Für diese Konstanten oder Berechnungen kann man Namen festlegen und diese dann in den Formeln verwenden.
-> Die Namen vergibt man im Dialog "Einfügen, Namen, Definieren / Festlegen".
Legt man dort etwa den Namen "MwSt" fest, und gibt in der Zeile "Bezieht sich auf" den Wert "16%" ein, kann man überall in der Arbeitsmappe mit dem Namen "MwSt" rechnen, also etwa mit

=A1*MwSt

die Mehrwertsteuer zum Betrag in Zelle A1 berechnen.
-> Ein weiteres Beispiel:

Wenn man den Namen des aktuellen Monats benötigt, fügt man unter "Einfügen, Namen, Definieren / Festlegen" den Namen "akt_ Monat" hinzu und trägt in der Zeile "Bezieht sich auf" die Formel

=Text(Heute();"MMMM")

ein. Mit

"=akt_Monat"

erhält man dann in jeder beliebigen Zelle der Arbeitsmappe den ausgeschriebenen aktuellen Monatsnamen.
-> Zellen benennen: Einfügen / Namen / Festlegen /

Oder Zelle AX markieren, die Listbox aufmachen, in der "AX" angezeigt wird, "AX" überschreiben mit "namen"

mit [ Enter ] bestätigen.
[ Übernimmt sonst benachbarte Namen: der Name "xyz" wird automatisch vorgeschlagen, wenn ein Feld mit diesem Text in der Nähe ist ]

-> Zellennamen löschen: Einmal vergebene Zellennamen können nicht überschrieben oder neu definiert, sondern nur gelöscht werden:

Einfügen / Namen / Festlegen / Löschen / + (ggf. neu) Hinzufügen



^  Der Namen:


^  Prüfen:



^  Namensvergabe ist auch an Blöcke möglich:


  1. z. B. in einer Tabelle unter "Erlöse" eingetragenen Beträge allesamt markieren

  2. Einfügen / Namen / Festlegen /  "einnahmen"

  3. Dann:  Zelle XY:   =SUMME(einnahmen)

  4. Analog: "ausgaben"

  5. Ergebnis:   =SUMME(einnahmen)-SUMME(ausgaben)

 


Erlaubte Namen:





****************




^   Daten verknüpfen:


 

Die Formel für die Adressierung zwischen unterschiedlichen Tabellen lautet übrigens:
='TabellenName'!E12
 

( Nachträgliches Umbenennen der Tabelle ist unschädlich innerhalb der Mappe )

Zwischen Mappen lautet sie =[Mappe1.xls]Tabelle1!$G$12




****************


In Zellen

Siehe tp_excel.txt



****************




^   Füllfunktionen:

 

^  Neue, unbekannte Reihen erstellen, z. B. Namen:





Entweder:

  1.   Extras / Optionen / Autoausfüllen

  2.   Neue Liste eingeben mit Zeilenschaltung; letze Eingabe ohne



Oder:
 

  1.   Liste schreiben

  2.   Extras / Optionen / Autoausfüllen / importieren



Oder:



^  Diese neue Liste einfügen:






****************




^   Wenn - Dann - Funktion

 

        > größer
       >= größer gleich
= gleich
> kleiner
<= kleiner gleich
<> ungleich !!



^  Beispiel 1:





^ Einfache Meldung )


=WENN(B34=100;"Prima, 100!";"Schade, keine 100.")





^  Beispiel 2:


^ Anrede automatisieren )


Vorbereitung:


Name Vorname Geschlecht
Schultze Charly m
Meier Hugo m
Möller Charlotte w

 

( Alternative Methoden )


^  Beispiel 3:



^ Eingabeaufforderung )


Tabelle:


Preis
MwstKennz.
MWSt.
Brutto
100
1
16
116
100
2
7
107
100
0
0
100

 

^  Formel:

=WENN(E32=1;D32*16/100;WENN(E32=2;D32*7%;WENN(E32=0;0;" Mwstkennz. erfassen!")))


^  Erweitert:

=WENN(ISTTEXT(A32);"Bitte Preis erfassen!";WENN(ISTLEER(A32);"Bitte Preis erfassen!";WENN(ISTLEER(B32);"MwstKennz. erfassen!";WENN(B32=1;A32*16/100;WENN(B32=2;A32*7%;WENN(B32=0;0;"MwstKennz. erfassen!"))))))



****************




^   Funktionen / Fehlermeldung:



Zelle enthält numerischen Wert :

=WENN(ISTZAHL(A3);"Zelle enthält numerischen Wert";"Zelle enthält keinen numerischen Wert")


Zelle enthält Wert :

=WENN(ISTLEER(A4);"Zelle ist leer";"Zelle enthält Wert")


Zelle enthält Text :  

=WENN(ISTTEXT(A5);"Zelle enthält Text";"Zelle enthält keinen Text")




****************




^   Wenn / Und / Oder / Funktion


Beispielsweise im Bereich Lagerverwaltung / Lagerbestand



Beide Bedingungen erfüllt:

=WENN(UND(A26=17;B26="A");"Beide Bedingungen erfüllt";"Bedingungen NICHT erfüllt!


Ein "A" kommt vor:

=WENN(ODER(B27="A";C27="A";D27= "A");"Ein A kommt vor!";"Kein A kommt vor!


X cm Schnee:

=WENN(ODER(ISTZAHL(A28);ISTZAHL(B28);ISTZAHL(C28));A28&"cm Schnee!";"Nun ja.")


Einzahl / Mehrzahl:

=WENN(A1=1; " Palette"; "Paletten ") [ Oder als Zahlenformat ]





Waren- 
gruppe
Basis- 
preis
Menge
Gesamt- 
betrag
Rabatt 1
Rabatt 2
End- 
betrag
A
70,00 DM
7490,00 DM
14,70 DM
-
DM
475,30 DM
B
105,00 DM
101.050,00 DM
26,25 DM
-
DM
1.023,75 DM
A
56,00 DM
201.120,00 DM
33,60 DM
22,40 DM
1.064,00 DM
 

 

=WENN(A13="B";B13*C13-B13*C13*2,5%;WENN(UND(A13="A";B13*C13>1000);B13*C13-B13*C13*3%-B13*C13*2%;WENN(A13="A";B13*C13-B13*C13*3%;B13*C13)))
 





 Altersberechnungen:

 
Geburtsdatum
Eintrittsgeld
Basispreis:
42,50 DM
12.01.72
42,50 DM
42,50 DM
 
14.07.89
17,00 DM
42,50 DM
 
20.06.84
25,50 DM
42,50 DM
 

 

=WENN(HEUTE()-A4<12*365,25;basispreis*40%;WENN(HEUTE()-A4<16*365,25;basispreis*60%;basispreis))





****************




^   Verweise auf Spalten und Zeilen


Die Funktion SVERWEIS dient dazu, aus einer Tabelle die zu einem Wert in einer Spalte zugehörigen Werte aus einer anderen Spalte zu ermitteln:

( Entsprechend WVERWEIS für Zeilen )



Nr. Artikel Preis
0 nix 0 DM
100 Hose 85,00 DM
200 Hemd 58,00 DM
300 Schal 20,00 DM
400 Mantel 1.290,00 DM
500 Schuh 198,00 DM



=WENN (ISTLEER(A10);"Bitte Artikelnummer erfassen";WENN((A10)<>SVERWEIS(A10;artikel;1);"Artikelnummer nicht vorhanden";SVERWEIS(A10;artikel;3)))

=WENN (ISTLEER(A10);"Bitte Artikelnummer erfassen";WENN((A10)<>SVERWEIS(A10;artikel;1);"Artikel nicht ermittelt";SVERWEIS(A10;artikel;2)))



Im ( beliebigen ) Feld A10 werden hier die Artikelnummern eingetippt.

[ Die erste 0-Zeile verhindert eine #NV- Fehlerausgabe bei zu kleinen Zahleneingaben ]


Achtung:



NB: Mit Hilfe einer Hilfszelle, welche die gefundene Zeile ermittelt, läßt sich die Umgebung eines SVERWEIS - Wertes anzeigen. Damit kann nicht nur der nächstkleinere, sondern auch der nächstgrößere Wert angezeigt werden. Unter Umständen auch mehrere und gleiche Werte.


Excel 97 - Tabelle: Funktionen





****************




^   Mathematische Funktionen:

 

Beispiel: Quartalsumsätze                    

 
1. Filiale
2. Filiale
3. Filiale
Gesamt
Quartal I
2.350.000,00 DM
1.870.000,00 DM
2.790.000,00 DM
7.010.000,00 DM
Quartal II
2.612.000,00 DM
2.095.000,00 DM
2.812.000,00 DM
7.519.000,00 DM
Quartal III
2.140.000,00 DM
1.970.000,00 DM
2.570.000,00 DM
6.680.000,00 DM
Quartal IV
2.860.000,00 DM
2.583.000,00 DM
2.973.124,57 DM
8.416.124,57 DM
Gesamt
9.962.000,00 DM
8.518.000,00 DM
11.145.124,57 DM
29.625.124,57 DM

  

Excel 97 - Tabelle: Quartalsumsätze 1

· Größter Umsatz 2.973.124,57 DM =MAX(B4:D7)
· Kleinster Umsatz 1.870.000,00 DM =MIN(B4:D7)
· Anzahl 1 der Werte 12 =ANZAHL(B4:D7) [Numerische Werte]
· Gesamtsumme 29.625.124,57 DM =SUMME(B4:D7)
· Mittelwert 1 2.468.760,38 DM =B14/B13
· Mittelwert 2 2.468.760,38 DM =MITTELWERT(B4:D7)
· Anzahl 2 der Werte 12 =ANZAHL2(B4:D7) [Alle Werte]



 
1999 
2000 
Abweichung
in %
 =C3/B3-1
Quartal I
7.010.000,00 DM
5.352.000,00 DM
-23,65% 
Zahlenformat Benutzerdefiniert:
Quartal II
7.519.000,00 DM
5.354.000,00 DM
-28,79% 
+ #.##0,00%;[Rot]- #.##0,00%
Quartal III
6.680.000,00 DM
5.518.000,00 DM
-17,40%
 
Quartal IV
8.416.124,57 DM
7.170.000,00 DM
-14,81%
 
Gesamt
29.625.124,57 DM
23.394.000,00 DM
-21,03% 
 

  


Excel 97 - Tabelle: Funktionen





^   Winkelberechnung:

 

Zu Bogenmass- und Winkelfunktionen ( Sinus und Kosinus etc. ) siehe hier.




****************




^   Diagramme:

 
 

    

Excel 97 - Tabelle: Diagramme 1

Excel 97 - Tabelle: Diagramme 2





****************




^   Ausdruck:

 
 







Ende - vorläufig.

  

Alle hier aufgeführten Excel 97 - Tabellen: gepackt

 




Letzte Aktualisierung: 01 / 10


ZU1 SeiteRÜCK
© 1999 Jürgen Hinrichs

http://www.erleuchtet.gmxhome.de/index-g.htm



  Stichwortsuche:  

 Wie suche ich richtig mit FreeFind?

Suchbegriff(e) bitte EXAKT eingeben; ggf. mit Platzhalter abkürzen:
formatieren findet nur formatieren; format* findet auch Formate, Formatierung, etc.

     Von FreeFind
     Inhaltsverzeichnis